SPSS TUTORIAL

SPSS® Tutorial

TUTORIAL CONTENT

1- GETTING STARTED
2- IMPORTING DATA
3- MANIPULATING DATA

By Oussama BenKhadral
Master of Science in Information Systems
School of Computer Science, Telecommunications and Information Systems
DePaul University
Chicago, IL, 60604, USA
{obkhadra@hotmail.com}

! Modified by Raffaella Settimi on 08/30/2007



SPSS TUTORIAL

1 GETTING STARTED

This tutorial provides a quick review of the basic features of SPSS Statistical
Software. In addition to this brief introduction, we recommend using the SPSS tutorial that
is found under the Help menu in SPSS. The SPSS tutorial is extremely helpful and will
provide more detailed information about the various SPSS functionalities.

SPSS is available in all DePaul and CTT labs, and is installed in the CT1 terminals. See
the end of this tutorial for information about CTT terminals. A trial version of SPSS 15 can

be downloaded from the SPSS website at http://www.spss.com/downloads/ (Select SPSS

Base in the Product Name Selection list. Look under “Product Demos” in the results page,
and click on the SPSS 15.0 for Windows link.) The trial version is for evaluation only and
will expire in 14 days. Students can also purchase a six-month license at e-academy:

http://estore.e-academy.com/

In this section, I will guide you on the first steps of using SPSS application. Here is the list of
tasks discussed in the tutorial:

1- TLaunch SPSS application

2- Open an existing SPSS Data file

3- Calculating Simple Statistics

4- Viewing Result Output

5- Connecting to CTT terminals to use SPSS remotely

1- Launching SPSS Application

The path to open the SPSS Application is as follows:
Start>Programs>SPSS for Windows>SPSS xx.x for Windows
Where xx.x is the version number (e.g. 14.0)

Once you launch the program the following window appears:


http://www.spss.com/downloads/
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Figure 1.1 SPSS Starting Window

Many options are available after opening SPSS:

1.

»

Run the tutorial: A very useful for learning more SPSS functionalities in a very
attractive environment (recommended for first time users).

Type in data: Open a new data file in SPSS

Run an existing query: You import data from a previous selection syntax

Create a new query using Database Wizard: very powerful tool for importing data from
any type of RDBMS using Microsoft ODBC (Open Database Connectivity)

Open an existing data source: Open an existing SPSS data file (*.sav spss datafile
extension)

Open another type of file: Open other type of SPSS files (e.g. *.spo for SPSS output
document)

2- Opening an existing SPSS data file

Choose “Open an existing data source”.
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Figure 1.2 SPSS Open File Window

When you choose “open an existing data source” a window (figure 1.2) will appear and select
“Employee data” data file name and click on open

You will notice a window having similar environment as MS Excel. In the SPSS Data Editor
window there are 2 different views:

- Data view : for visualizing the entire data set
- Variable view: for visualizing details concerning the variables.

The menu bar of SPSS Data Editor is organized in the same way as the data mining process:

- File: It is used for opening/importing data from data files or databases

- Data: It is used for selecting and cleaning process

- Transform: It is used for calculating new values or transforming current values
by applying logical statements.

- Analyze: It is used for applying statistical and data mining techniques and
visualizing the outputs

- Graph: graphical visualization of data mining techniques.

For more information concerning the different tools available in each category,
please use the help>tutorial.
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Figure 1.3 SPSS Open Data Editor Window (Data View)

In the data view (figure 1.3) window the variables name are in the first row and each row

(132

represents one case. The missing values in a field is represented (by default) by “.” a dot.

In the variable view (figure 1.4) you can edit the characteristics of each variable: the most
useful ones are:

Name: this is should be unique and does not exceed 8 characters. (The first
character of a variable name should be a letter)
Type: determine the data type of the variable (you can choose from numeric,
date, currency and string)
Label: it is useful to specify the label of the variable for visualization
Values: Here you specify the label of a given field value (e.g in case of “m” for
gender you specify that it represent “male”)
Missing: You specify which value to give for a missing value
Measure: It is important to specify what kind of variable it is
o Ordinal: the values of the variables are sorted (e.g level of satisfaction)
o Nominal: the values of the variable are categorical (e.g gender)
o Scale: the values of the variable are continue (e.g. salary)
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Figure 1.4 SPSS Open Data Editor Window (Variable View)

After opening the SPSS data file, we will apply some statistical technique on the data and
visualize the output result in the SPSS Output window.

3- Calculating Simple Statistics

The next logical step in the analysis is to apply statistical or data mining tools on the data.
The “Analyze” menu in the menu bar is the best place for this purpose.

Click on “Analyze”

Select “descriptive Statistics”

Open “Frequencies...”

The opening window of “Frequencies” appears as shown in figure 1.5a.
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Figure 1.5a SPSS Frequencies window

To select a variable from the variable list for analysis, click on the variable for selection then
click on the “arrow” (>) button in the middle of the window (figure 1.5b). Then click on
OK for viewing Frequency result of the Employment Category.
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Figure 1.5b SPSS Frequencies window

4- Viewing SPSS Result Output

The SPSS Output window (figure 1.6) contains an outline and a content pane. You can click
on an item in the outline pane to visualize it in the content pane.
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Figure 1.6 SPSS Output window

In the SPSS Output window, you can export the results into other format (e.g html) or print
them.



SPSS TUTORIAL

2 IMPORTING DATA

The SPSS Data Editor is designed to handle a wide variety of data source, including:
- Spreadsheets (e.g. Excel format)
- Databases files using ODBC tool (such Access files)
- Tab-delimited and other types of ASCII text files

IMPORT DATA FROM EXCEL
In this section I will introduce you on how to import data from Excel

To open a data file, from the menu in the data Editor window choose:

1. Click on “File”
2. Select “Open data” and locate the file in your hard disk. Remember to select the Excel
(“xIs”) files in the “Files of type” box.
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3. Click on the data file to be imported
4. A data import wizard will appear. NOTE: If the data first row contains the variable
names, check the box “read variable names from the first row of data”. Do not
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check this box if the first row of data contains data. If the box is checked, the first row

will not be read. Click ok
5. The Data View will appear showing the imported data. Always double check that the
data set was imported correctly and its entirety.
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6. Click on “Variable View” tab to modify the variables properties. For instance you can
modify the variable names here.
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To save the data in a SPSS format choose “Save as” from the File menu and save the data in

a .sav file.

IMPORT DATA FROM A TEXT FILE (ASCII)

Data are often saved in text files, with values aligned in columns. SPSS has a easy to use

wizard to import data from text files. To run it:
1. Click on “File”

2. Select “Open data” and locate the file in your hard disk. Remember to select the
appropriate file extension in the “Files of type” box — e.g. .txt files.
3. Tollow the instructions of the wizard that will guide you through the entire process.
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IR R0 | 81285 i ‘Whelcome to the text import wizard!
240003 T 4033
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3 RUNNING SPSS REMOTELY - INTRODUCTION TO TERMINAL
SERVICES:

SPSS is available in all DePaul labs. You can also access SPSS remotely by using our CDM
terminals. This option is only for students who have a fast Internet connection.

INTRODUCTION TO TERMINAL SERVICES:

Terminal Services allow multiple users to access a remote computer as if they were using the
machine locally. Terminal Servers within CDM allow students who cannot access lab resources
or install applications on their home computers to have full access to the applications needed to
complete course work.

Connecting to the CDM Terminal Servers

1. Login into the CDM User Account Activation Application at
https://accountactivate.cdm.depaul.edu/ViewAccounts.aspx using your Campus
Connect username and password

2. Activate your “myCDM” CSTCIS Account.

Take note of your username and domain.

4. Launch the Remote Desktop Client from your computer that can be found in the
Programs list under Accessories. If you cannot find it, do the following: Click on Start >
Programs > Accessories > Communications > Remote Desktop Connection.

If the application is not available on your PC, download and install the Remote Desktop
Client from
http://www.microsoft.com/downloads/details.aspx?FamilylD=80111f21-d48d-
426e-96¢2-08aa2bd23a49&DisplayLang=en .

5. Type in the Server name into the Computer Name text box:
ctiterminals.cstcis.cti.depaul.edu

w

#% Remote Desktop Connection

Remote Desktop

' Connection
-

LCamputer: ‘ chiterminals. cstois. ch. depaul edy “

Uzer name:  CSTCISrsettimi

'ou will be asked for credentiale when pou connect.

[ Connect H Cancel H Help ”thiu:uns» ]

6. If the step is successful, you will see a Windows XP desktop and you can then launch
SPSS15 from the terminal machine clicking on Start> All Programs> SPSS

7. Notice that in this case SPSS runs remotely on the terminal computer, and not on your
local machine. This means that the data files must be saved on the remote terminal


http://www.microsoft.com/downloads/details.aspx?FamilyID=80111f21-d48d-426e-96c2-08aa2bd23a49&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=80111f21-d48d-426e-96c2-08aa2bd23a49&DisplayLang=en
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computer in order to be imported into SPSS, and the SPSS output files will be saved on
the remote computer (and not on your local machine).
You can easily transfer files from/to your local machine to/from the remote terminal
computer by using a web email account and attaching the files to email messages.
8. THIS STEP IS OPTIONAL — | RECOMMEND IT ONLY IF YOU WANT TO USE/SAVE FILES ON

YOUR LOCAL HARDDRIVE.
Select the “Options >>" button in the Remote Desktop Connection and select “Local
Resources”.

a. Select “Do not play” under “Remote Computer Sound”

b. If you want to be able to use your local hard drives and printer select “Disk

drives” and “Printers” under the “Local Devices” section.

2 Remote Desktop Connection

| General | Display | Local Resources | Programs | Experience |

Remote computer sound

AV
& Do not play v
&

Keyboard

e} Apply Windows key combinations
B (for example ALT+TAB)

0N the remote computer v \

Local devices

Connect automatically to these local devices when logged on
P to the remote computer:

Disk drives
Printers
[] Serial ports

[ Connect ” Cancel ][ Help ] [ Options << ]

9. Select the connect button to connect to the Terminal Server.
10. Login to the Terminal Server using the username and domain you copied in Step (2). The
password should be same as your Campus Connect password.

Log On to Windows

{
_

7 Windows Server2003
¥ Enterprise Edition

Capyright © 1885-2003 Microsoft Corporation

User name: I aschmitz
Password: I sssssses
logonto:  |CSTCIS =]

QK I Cancel | Shut Dc-v-.-n‘..l Options << |

11. You are now ready to begin using the software on the remote Terminal Server.




